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1. Overview
Screen Prototyping is an easy-to-use software application designed to handle the early stage of the software development process. 
Screen Prototyping helps you to: 
· sketch screen prototypes of your product and arrange them in groups or scenarios.
· experiment interactively with his clients, and quickly visualize scenarios of his software application, even before the coding has started.
· communicate your product developments to your clients and discuss design ideas with them.
· create five prototypes in ten minutes without any programming knowledge.  
2. Getting Started


Installing the software
To install the software:
<need to get info on installation>
Registering
Though you can avail the unregistered 30-day trial version facility, it is highly recommended that you register to get the full version of the application.

Registering of the application ensures you:
· No watermark image on your screens

· No annoying messages of time limits

· 12 months of free upgrades and free e-mail support

If you are using the trial version, do the following to register yourself:

1. Click Register on the Help menu, 
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2. In the Buy the Full Version of Mockup Screens dialog box, click the Buy the Full Version Now... button.
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The http://mockupscreens.com/index.php?page=Buy_Now page is displayed where you buy your license by opting one of the following packages:
· Single User $79

· Team $149

· Corporate $319

· Education $199

3. Select a package based on your requirements.

4. Fill in the registration form and click Submit.
Once you are successfully registered, you will receive the registration code to your mail ID (which you have provided in the registration form.)
5. In the Buy the Full Version of Mockup Screens dialog box, click the Enter your registration Code... button.
6. In the prompted message box, enter the registration code and click OK.
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3. Understanding the Interface


The Screen Prototyping application comes with a user-friendly interface and is easy to use. The simplified design of the interface, which is almost confined to a single screen, enables you to perform the tasks easily and quickly.

Menu Bar

The menu bar consists of five menus: File, Edit, Drawing, Tools, and Help.
File: Using the File menu, you can: 

· create a new project and open an existing project

· save the project in a specified location

· print the whole project or a selected group or the current screen

· open the recent files

· exit the application
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Edit: Using the Edit menu, you can:
· undo and redo the previously performed actions
· copy, cut, and paste
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Drawing: Using the Drawing menu, you can
· create, delete, and rename a screen

· create, delete, and rename a group

· transform one element to the other

· show or hide the grid

· bring one element to front or send it to back if there are two elements
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Tools: Using the Tools menu, you can:
· run a slideshow of the screens
· take a snapshot of a screen and either save it or copy it to the clipboard

· export the whole project or a selected group to a HTML page
· export the whole project or a selected group to a XML page

· export the whole project or a selected group to a scenario

· import a scenario into the root group or a selected group

· set options in the following topics: Editor, Export, Print, Slideshow, Snapshot, and General.
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Help: Using the Tools menu, you can:

· go to the product help

· register yourself and buy the Screen Prototyping application

· visit the Screen Prototyping website
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Tool Bar
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In addition to the menu functions, the tool bar consists of some more functions. Using the tool bar, you can perform the following functions in the same order as displayed in the application:

· Create a new project and open an existing project

· Save a project

· Print a screen

· Undo and redo the previously performed actions

· Cut, copy, and paste

· Run a slideshow of the screens

· Take a snapshot of a screen and either save it or copy it to the clipboard

· Change the screen skin to Web or Black & White or Windows.

· Set options in the following topics: Editor, Export, Print, Slideshow, Snapshot, and General.

· Bold, italicize, and underline the text

· Change the font size and color of the text

· Align text to left, center, and right   
Elements

The screen elements are displayed in the left panel called Widgets. These elements are used to create a prototype of your product screen. You click elements in the left panel and click in the work area where you want the elements to appear. In this way, you create prototypes according to your requirement.
[image: image10.png]Button
Fild
Dropdown
Chectbox
Text

Tab
Inage
Radio

Lt

Tree
Frame
Line.
Table

Label Field
Label.Dropdown
Label List

Marks





The following image displays how the elements appear when you place them in the work area:
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Screens

The screens are displayed in the right panel called Screens. After you create screens in the work area, they are displayed in the Screens panel so that you can select any screen from the panel and work on it. The following image displays that a screen is created in the work area and it is displayed in the Screens panel.
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Basic and Advanced Options

You can set basic and advanced options for elements in the specified tab areas below the work area. The basic and advanced options vary from element to element. To set the options for an element, you need to select the element in the work area. You can also modify the options whenever you like.
The following image displays that when the table element is selected in the work area, the Advanced tab area is displayed where you can set the required options. To go to the basic options, you need to click the adjacent Basic tab.
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Comments
You can attach comments to the elements using the Comments tab below the work area. To attach a comment to an element, you need to select the element in the work area and type the comment in the Comments tab area. Your comment, attached to the element, is displayed in the comment box. 

To delete a comment, you need to select the element and remove the comment text from the Comments tab area.
The following image displays that the table element is selected in the work area and the text is typed in the Comments tab area. The comment is attachment to the element.
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4. Using Screen Prototyping Application

This chapter helps you perform different functions of the application. 

Managing Prototype Screens
This section consists of the following topics:
· Creating a Prototype Screen

· Choosing Elements into the screen
· Setting the Basic Options of an Element

· Setting the Advanced Options of an Element

· Setting element interactions

· Selecting multiple elements

· Adding Groups

· Deleting Groups

· Renaming Groups

· Organizing prototypes in scenarios
· Cut / Copy / Paste screen element(s)
· Export screens
Creating a Prototype Screen

To create a prototype screen:

7. Click New Screen on the Drawing menu (Or) right-click in the Screens panel and click New Screen. 
The new screen is displayed in the work area.
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Choosing Elements into the screen
To choose an element into the screen:
8. Click the element in the Widgets panel.
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9. Click on the screen in the work area.

The element comes onto the screen.
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Setting the Basic Options of an Element

To set the basic options:
10. Right-click the element on the screen and click Edit element on the context menu.
11. In the Basic tab area, do the following:

· Caption: Type a name for the element.

· Checked: Select or clear the check box to enable or disable the check box. This option is meant for the Checkbox element.
· Text: Type text in the box. This option is meant for the Text element.
· Transparent: Select the check box to make the text transparent. This option is meant for the Text element.
· Tab Captions: Type the tab captions in a list form in the box and the captions are displayed for the tabs. This option is meant for the Tab element.
· Active tab: In the drop-down list, select the tab which you want to be active. This option is meant for the Tab element.
· Select Gallery Image: Click the button to navigate and select a gallery image. This option is meant for the Image element.
· Select a Custom Image: Click the button to navigate and select a custom image. This option is meant for the Image element.
· Options: Type options in a list form in the box and the options are displayed as radio buttons. This option is meant for the Radio element.
· Selected Option: In the drop-down list, choose the option which you want to be displayed as selected. This option is meant for the Radio element.
· List Values: Type the list values in a list form in the box and the values are displayed as list values. This option is meant for List and Label.List elements.
· Tree Items: Type the tree items in a list form in the box and the items are displayed as tree items. This option is meant for the Tree element.
· Flip Diagonal: Select the check box to flip the line diagonally. This option is meant for the Line element.
· Columns: Type the column name in a list form in the box and the names are displayed as columns for the table element. This option is meant for the Table element.
· Table Data: Click the Edit button to enter table data. In the prompted Edit Table Values dialog box, you can
· add and delete columns
· add and delete rows
· paste data from an excel sheet
· Label: Type the label names in a list form in the box and the labels are displayed in the element. This option is meant for Label.Field, Label.Dropdown, and Label.List elements.
· Change Mark Icon: Click the button to select an icon from the box. This option is meant for the Marks element.
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Setting the Advanced Options of an Element

To set the basic options:

12. Select the element on the screen in the work area.

13. In the Advanced tab area, do the following:

· Disabled: Select the check box to disable the element. To enable the element, clear the check box. 
· Jump to Screen: Click the dotted button. In the prompted Select Screen to Jump message box, select a screen from the list and click OK.
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· Horizontal Scrollbar: Select the check box to create a horizontal scroll bar for the element.
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· Vertical Scrollbar: Select the check box to create a horizontal scroll bar for the element.
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· Connection Lines: Select the check box to enable connection lines for the Tree element.
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· Grid Lines: Select the Vertical Lines check box to enable the vertical lines in the table.
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Select the Horizontal Lines check box to enable the horizontal lines in the table.

[image: image24.png]



· Body Font: Using the formatting tolls, you can
· bold, italicize, and underline the text in the table
· change the font size and color of the text in the table
· align text to left, center, and right in the table
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Setting element interactions 
Selecting multiple elements

Cut / Copy / Paste screen element(s)
Adding Groups

Deleting Groups

Renaming Groups

Organizing prototypes in scenarios
Export screens
Moving between screens or screen groups
Moving screens to another groups
Add / delete screens
Importing screens into projects
Running the slide show of the screens

Printing screen or groups of screens

Creating snapshot of the current screen
5. Exporting/Importing screens

Exporting screens or groups into HTML

Export scenario to XML
Export project to XML

6. Skins


Windows skin

Black & white skin

Web skin
Switching between skins
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